About OverDrive for Mac

OverDrive for Mac is available for macOS versions 10.6 (Snow Leopard) through 10.14 (Mojave). If you're running one of these macOS versions, you can use OverDrive for Mac to download, listen to, and transfer MP3 audiobooks from your library.

OverDrive for Mac and OverDrive MP3 audiobooks are not compatible with the newest macOS version, 10.15 (Catalina), which was released on October 7, 2019. This is because Apple requires all apps in macOS Catalina or newer to be 64-bit, and OverDrive for Mac (which is required for downloading MP3 audiobooks) is 32-bit. If you're running macOS Catalina or newer, these are your audiobook options:

Last Updated: 16 October 2019 10:18 AM