Choose the image below that looks like the titles in your library's collection.

We recommend always using the latest version of Chrome, Edge, Firefox, Internet Explorer 11, or Safari to browse your library's OverDrive website on mobile devices and computers. If you're using Internet Explorer, you'll need at least Internet Explorer 10.

If you're using an Android or iOS (iPhone/iPad/iPod touch) device, we recommend using Android 4.0+ and iOS 9+, so you can enjoy borrowed titles in the latest version of the OverDrive app.

We recommend always using the latest version of Chrome, Edge, Firefox, Internet Explorer 11, or Safari to browse your library's OverDrive website on mobile devices and computers.

We also support Internet Explorer 8 or higher for most OverDrive library websites.

Last Updated: Jan 19, 2017 09:44AM EST